Nokogiri before 1.15.6 and 1.16.x before 1.16.2 (CRuby, when using the packaged libxml2) is affected by a use-after-free vulnerability in libxml2 (CVE-2024-25062) in the xmlTextReader module, which un...
Year Archive: 2024
EUVD Vulnerabilities (2024)
Browse security threats, CVE catalog items, and software security flaws mapped under the EUVD sequence for the year 2024.
CRITICAL (9.3)
CVSS 4.0
Source: VulnCheck
Aliases:
GHSA-rxg7-cvrw-9p73
CVE-2024-58378
Published: 2026-08-25
View Complete Profile →
CRITICAL (9.3)
CVSS 4.0
Source: VulnCheck
Nokogiri versions before 1.16.5 bundle libxml2 2.12.6, which is affected by CVE-2024-34459 in libxml2's xmllint tool. Nokogiri 1.16.5 upgrades the bundled libxml2 to 2.12.7 to address this. Per the ma...
Aliases:
CVE-2024-58377
GHSA-rpqg-75pv-92c9
Published: 2026-08-25
View Complete Profile →
EUVD-2024-19376
Actively Exploited
CRITICAL (9.6)
CVSS 3.1
Source: fortinet
A out-of-bounds write vulnerability in Fortinet FortiOS 7.4.0 through 7.4.2, FortiOS 7.2.0 through 7.2.6, FortiOS 7.0.0 through 7.0.13, FortiOS 6.4.0 through 6.4.14, FortiOS 6.2.0 through 6.2.15, Fort...
Aliases:
CVE-2024-21762
GHSA-v4hq-m4wr-6pmj
Published: 2024-02-09
View Complete Profile →